No components marked as affected
Resolved
MINDA systems are back online, integrations are operational
Monitoring
Halter's integration with MINDA is currently unavailable, while MINDA complete urgent maintenance on their systems. Contact the MINDA support team if you have urgent issues.